upgradeFromGit : add check_file_or_symlink function and use it during theme installation